Print Topic

Computer Q&A Board  /  Questions  /  Generic Host Process error
Posted by: 221 (Guest), February 8th, 2011, 2:07pm
On starting up Windows XP Home, this message appears:

Generic Host Process for Win32 Services has encountered a problem and needs to close.

I then have the usual options of sending an error report to Microsoft or not. I have found that if I send the report (or not) the message vanishes, after which I can do nothing - the PC freezes. Otherwise, I can use the machine as normal until I want to close down, when the message is cleared and the system freezes again, so I have no option but to force a shutdown with the on/off button. On restart, the message pops up again.

I have searched Microsoft's Knowledge Base, but all the suggestions either don't work or can't be downloaded. I did download a "fix" on another PC and copied it over, but it told me I didn't need it as I have SP3 and this is a fix for SP2. All the ideas that involve a restart don't work because I can't shut down cleanly. One suggestion was to scan for viruses using "Hitman Pro 3", but I've never heard of it before and can't find a review of it, so I'm dubious. AVG doesn't find any viruses and CCleaner fixed a few registry problems, but the message is still there!! Any clues, anyone, please?
Posted by: 221 (Guest), February 14th, 2011, 4:33pm; Reply: 1
Further to my previous post, by chance I downloaded the latest automatic Microsoft updates, one of which was the Microsoft Malicious Software Removal Tool. When I ran it, it detected a virus known as "Alureon.H" which is reputed to be an especially nasty one. It only partly removed it and instructed me to complete the removal using a fully-fledged virus removal tool. I have been using AVG for a long time, so I ran it, but it failed to detect the virus. An Internet search, however, pointed me to another Microsoft offering, their "Security Essentials" package. To cut a long story short, this seems to have removed the problem (together with several others that AVG had missed), and the "Win32 Services" error message no longer appears, which is great news. I was left with another problem when I tried to uninstall AVG to avoid possible conflicts between the two anti-virus products, but each time I did so it reappeared. I then found that AVG have created a special removal tool, which I downloaded and ran, and AVG has now gone! Anyone else who has that problem may wish to know about the special removal tool, as without it, it looks like another virus infection.
Posted by: 112 (Guest), February 15th, 2011, 9:59am; Reply: 2
Good, I am glad you figured it out.  Thank you for sharing your results with us.
Print page generated: August 9th, 2020, 7:33am